debian/rules
changeset 12641 002ae96afeab
parent 12631 8f22b69ea890
child 12656 91178bc271c7
equal deleted inserted replaced
12640:de1c0721656e 12641:002ae96afeab
     4 
     4 
     5 # Uncomment this to turn on verbose mode.
     5 # Uncomment this to turn on verbose mode.
     6 # export DH_VERBOSE=1
     6 # export DH_VERBOSE=1
     7 
     7 
     8 export PYBUILD_NAME=cubicweb
     8 export PYBUILD_NAME=cubicweb
     9 export PYBUILD_DISABLE_python2=test
       
    10 export PYBUILD_DISABLE_python3=test
     9 export PYBUILD_DISABLE_python3=test
    11 
    10 
    12 %:
    11 %:
    13 	dh $@ --with python2,sphinxdoc --buildsystem=pybuild
    12 	dh $@ --with python3,sphinxdoc --buildsystem=pybuild
    14 
    13 
    15 override_dh_auto_build: export http_proxy=127.0.0.1:9
    14 override_dh_auto_build: export http_proxy=127.0.0.1:9
    16 override_dh_auto_build: export https_proxy=127.0.0.1:9
    15 override_dh_auto_build: export https_proxy=127.0.0.1:9
    17 override_dh_auto_build:
    16 override_dh_auto_build:
    18 	dh_auto_build
    17 	dh_auto_build
    19 ifeq (,$(findstring nodocs, $(DEB_BUILD_OPTIONS)))
    18 ifeq (,$(findstring nodocs, $(DEB_BUILD_OPTIONS)))
    20 	PYTHONPATH=. sphinx-build -N -bhtml doc/ debian/cubicweb-doc/html
    19 	PYTHONPATH=. sphinx-build -N -bhtml doc/ debian/cubicweb-doc/html
    21 endif
    20 endif
    22 
    21 
       
    22 override_dh_auto_install:
       
    23 	dh_auto_install
       
    24 	mv debian/python3-${PYBUILD_NAME}/usr/bin/cubicweb-ctl \
       
    25 		debian/cubicweb-ctl/usr/bin/cubicweb-ctl
       
    26 
    23 override_dh_installchangelogs:
    27 override_dh_installchangelogs:
    24 	dh_installchangelogs -Xdoc/changes
    28 	dh_installchangelogs -Xdoc/changes
    25 
    29