equal
deleted
inserted
replaced
25 debian/cubicweb-ctl/usr/bin/cubicweb-ctl |
25 debian/cubicweb-ctl/usr/bin/cubicweb-ctl |
26 |
26 |
27 override_dh_installchangelogs: |
27 override_dh_installchangelogs: |
28 dh_installchangelogs -Xdoc/changes |
28 dh_installchangelogs -Xdoc/changes |
29 |
29 |
|
30 # Should extra sections in requires.txt go to Recommends, Suggests or be |
|
31 # ignored? |
|
32 # |
|
33 # All sections must be listed so we don't forget any in cases of future |
|
34 # changes. |
|
35 |
|
36 RECOMMENDS_SECTIONS = ext crypto ical pyramid rdf |
|
37 SUGGESTS_SECTIONS = captcha zmq |
|
38 # sparql currently requires fyzz which is not compatible with Python 3 |
|
39 IGNORED_SECTIONS = sparql |
|
40 |
|
41 override_dh_python3: |
|
42 @set -e && trap 'rm -f requires-sections debian-sections' EXIT && \ |
|
43 sed -n -e 's/\[\(.*\)\]/\1/p' cubicweb.egg-info/requires.txt | sort > requires-sections && \ |
|
44 printf "%s\n" $(RECOMMENDS_SECTIONS) $(SUGGESTS_SECTIONS) $(IGNORED_SECTIONS) | sort > debian-sections && \ |
|
45 FORGOTTEN_SECTIONS=$$(comm -23 requires-sections debian-sections) && \ |
|
46 if [ "$$FORGOTTEN_SECTIONS" ]; then \ |
|
47 echo "The following sections are not listed in debian/rules:" && \ |
|
48 echo "$$FORGOTTEN_SECTIONS" && \ |
|
49 echo "Please add them in either RECOMMENDS_SECTIONS, SUGGESTS_SECTIONS or IGNORED_SECTIONS" && \ |
|
50 exit 1; \ |
|
51 fi |
|
52 dh_python3 \ |
|
53 $(foreach section,$(RECOMMENDS_SECTIONS),--recommends-section=$(section)) \ |
|
54 $(foreach section,$(SUGGESTS_SECTIONS),--suggests-section=$(section)) |