debian/rules
changeset 12641 002ae96afeab
parent 12631 8f22b69ea890
child 12656 91178bc271c7
--- a/debian/rules	Tue Jun 11 09:40:12 2019 +0200
+++ b/debian/rules	Wed Jun 05 15:38:29 2019 +0200
@@ -6,11 +6,10 @@
 # export DH_VERBOSE=1
 
 export PYBUILD_NAME=cubicweb
-export PYBUILD_DISABLE_python2=test
 export PYBUILD_DISABLE_python3=test
 
 %:
-	dh $@ --with python2,sphinxdoc --buildsystem=pybuild
+	dh $@ --with python3,sphinxdoc --buildsystem=pybuild
 
 override_dh_auto_build: export http_proxy=127.0.0.1:9
 override_dh_auto_build: export https_proxy=127.0.0.1:9
@@ -20,6 +19,11 @@
 	PYTHONPATH=. sphinx-build -N -bhtml doc/ debian/cubicweb-doc/html
 endif
 
+override_dh_auto_install:
+	dh_auto_install
+	mv debian/python3-${PYBUILD_NAME}/usr/bin/cubicweb-ctl \
+		debian/cubicweb-ctl/usr/bin/cubicweb-ctl
+
 override_dh_installchangelogs:
 	dh_installchangelogs -Xdoc/changes