debian/rules
author Denis Laxalde <denis.laxalde@logilab.fr>
Fri, 08 Feb 2013 22:12:46 +0000
branchstable
changeset 701 f752089479ce
parent 535 47246c32e0fb
child 725 235a942eba3f
permissions -rwxr-xr-x
add a duplicate option in touch

#!/usr/bin/make -f

%:
	dh $@ --with python2 --buildsystem=python_distutils

build:
	dh build --with python2 --buildsystem=python_distutils
	$(MAKE) -C docs

.PHONY: build

override_dh_auto_test:
	cd tests &&  python run-tests.py --with-hg=`which hg`

override_dh_python2:
	# avoid conflict with mercurial's own hgext/__init__.py
	find debian -name __init__.py -delete
	dh_python2