debian/rules
author Pierre-Yves David <pierre-yves.david@logilab.fr>
Thu, 30 Aug 2012 14:01:29 +0200
branchstable
changeset 535 47246c32e0fb
parent 531 b18b00036355
child 725 235a942eba3f
permissions -rwxr-xr-x
pkg-debian: remove conflicting __init__.py files

#!/usr/bin/make -f

%:
	dh $@ --with python2 --buildsystem=python_distutils

build:
	dh build --with python2 --buildsystem=python_distutils
	$(MAKE) -C docs

.PHONY: build

override_dh_auto_test:
	cd tests &&  python run-tests.py --with-hg=`which hg`

override_dh_python2:
	# avoid conflict with mercurial's own hgext/__init__.py
	find debian -name __init__.py -delete
	dh_python2