debian/rules
author Pierre-Yves David <pierre-yves.david@ens-lyon.org>
Fri, 08 Feb 2013 21:43:00 +0000
branchstable
changeset 699 dba3ed9f2c4f
parent 535 47246c32e0fb
child 725 235a942eba3f
permissions -rwxr-xr-x
amend: prune replacement commit without sucessors This align with the core behavior of `commit --amend`. All user of rewrite are not responsible for creating their own marker.

#!/usr/bin/make -f

%:
	dh $@ --with python2 --buildsystem=python_distutils

build:
	dh build --with python2 --buildsystem=python_distutils
	$(MAKE) -C docs

.PHONY: build

override_dh_auto_test:
	cd tests &&  python run-tests.py --with-hg=`which hg`

override_dh_python2:
	# avoid conflict with mercurial's own hgext/__init__.py
	find debian -name __init__.py -delete
	dh_python2