debian/rules
author Denis Laxalde <denis.laxalde@logilab.fr>
Mon, 03 Dec 2012 14:41:14 +0100
branchstable
changeset 644 8e41d5b78dff
parent 535 47246c32e0fb
child 725 235a942eba3f
permissions -rwxr-xr-x
support -r option in prune, add a test for this Also localize options in fold.

#!/usr/bin/make -f

%:
	dh $@ --with python2 --buildsystem=python_distutils

build:
	dh build --with python2 --buildsystem=python_distutils
	$(MAKE) -C docs

.PHONY: build

override_dh_auto_test:
	cd tests &&  python run-tests.py --with-hg=`which hg`

override_dh_python2:
	# avoid conflict with mercurial's own hgext/__init__.py
	find debian -name __init__.py -delete
	dh_python2