debian/rules
author Pierre-Yves David <pierre-yves.david@logilab.fr>
Mon, 17 Dec 2012 14:33:01 +0100
changeset 630 722b52c75f02
parent 535 47246c32e0fb
child 725 235a942eba3f
permissions -rwxr-xr-x
compat: adapt to upstreaming of divergent logic successorsset and divergent logic have been moved into core by changeset 4bec77e62c00::e411fd79ca69 We drop dedicated code in evolve.

#!/usr/bin/make -f

%:
	dh $@ --with python2 --buildsystem=python_distutils

build:
	dh build --with python2 --buildsystem=python_distutils
	$(MAKE) -C docs

.PHONY: build

override_dh_auto_test:
	cd tests &&  python run-tests.py --with-hg=`which hg`

override_dh_python2:
	# avoid conflict with mercurial's own hgext/__init__.py
	find debian -name __init__.py -delete
	dh_python2