debian/rules
author Pierre-Yves David <pierre-yves.david@logilab.fr>
Fri, 25 Jan 2013 16:31:29 +0100
changeset 656 4cd65437b704
parent 535 47246c32e0fb
child 725 235a942eba3f
permissions -rwxr-xr-x
test: drop rebase test We assume that the mercurial rebases tests suite is strong enough now.

#!/usr/bin/make -f

%:
	dh $@ --with python2 --buildsystem=python_distutils

build:
	dh build --with python2 --buildsystem=python_distutils
	$(MAKE) -C docs

.PHONY: build

override_dh_auto_test:
	cd tests &&  python run-tests.py --with-hg=`which hg`

override_dh_python2:
	# avoid conflict with mercurial's own hgext/__init__.py
	find debian -name __init__.py -delete
	dh_python2