debian/rules
author Patrick Mezard <patrick@mezard.eu>
Sat, 13 Oct 2012 16:31:52 +0200
branchstable
changeset 580 4676650f4f9d
parent 535 47246c32e0fb
child 725 235a942eba3f
permissions -rwxr-xr-x
test-stabilize-conflict.t: yes is not a standard shell utility And for some reason the test fails on OSX.

#!/usr/bin/make -f

%:
	dh $@ --with python2 --buildsystem=python_distutils

build:
	dh build --with python2 --buildsystem=python_distutils
	$(MAKE) -C docs

.PHONY: build

override_dh_auto_test:
	cd tests &&  python run-tests.py --with-hg=`which hg`

override_dh_python2:
	# avoid conflict with mercurial's own hgext/__init__.py
	find debian -name __init__.py -delete
	dh_python2