debian/rules
author Levi Bard <levi@unity3d.com>
Sat, 09 Feb 2013 16:21:22 +0100
changeset 704 2ec7c3673679
parent 535 47246c32e0fb
child 725 235a942eba3f
permissions -rwxr-xr-x
evolve: add --all argument.

#!/usr/bin/make -f

%:
	dh $@ --with python2 --buildsystem=python_distutils

build:
	dh build --with python2 --buildsystem=python_distutils
	$(MAKE) -C docs

.PHONY: build

override_dh_auto_test:
	cd tests &&  python run-tests.py --with-hg=`which hg`

override_dh_python2:
	# avoid conflict with mercurial's own hgext/__init__.py
	find debian -name __init__.py -delete
	dh_python2