debian/rules
author Pierre-Yves David <pierre-yves.david@ens-lyon.org>
Mon, 04 Feb 2013 18:07:09 +0100
branchstable
changeset 684 19a1a8f93c07
parent 535 47246c32e0fb
child 725 235a942eba3f
permissions -rwxr-xr-x
prune: detect bad input We accept multiple changeset folded into one successors. One changesets split in multiple successors. But we refuse multiple changesets split in multiple ones.

#!/usr/bin/make -f

%:
	dh $@ --with python2 --buildsystem=python_distutils

build:
	dh build --with python2 --buildsystem=python_distutils
	$(MAKE) -C docs

.PHONY: build

override_dh_auto_test:
	cd tests &&  python run-tests.py --with-hg=`which hg`

override_dh_python2:
	# avoid conflict with mercurial's own hgext/__init__.py
	find debian -name __init__.py -delete
	dh_python2