debian/rules
author Pierre-Yves David <pierre-yves.david@logilab.fr>
Tue, 23 Oct 2012 17:13:19 +0200
changeset 591 012e48e80840
parent 535 47246c32e0fb
child 725 235a942eba3f
permissions -rwxr-xr-x
evolve: require Mercurial 2.4 to work

#!/usr/bin/make -f

%:
	dh $@ --with python2 --buildsystem=python_distutils

build:
	dh build --with python2 --buildsystem=python_distutils
	$(MAKE) -C docs

.PHONY: build

override_dh_auto_test:
	cd tests &&  python run-tests.py --with-hg=`which hg`

override_dh_python2:
	# avoid conflict with mercurial's own hgext/__init__.py
	find debian -name __init__.py -delete
	dh_python2