debian/rules
branchstable
changeset 4911 ddfc0b16c9d7
parent 4909 56a8fbdd6090
child 4913 cac7e750422f
--- a/debian/rules	Tue Oct 15 11:39:58 2019 +0200
+++ b/debian/rules	Thu Oct 17 20:33:02 2019 +0200
@@ -4,10 +4,12 @@
 %:
 	dh $@ --with python2,sphinxdoc --buildsystem=pybuild
 
+ifeq (,$(filter nodoc, $(DEB_BUILD_OPTIONS)))
 override_dh_auto_build:
 	dh_auto_build
 	# Workaround for Sphinx in Debian Buster defaulting to Python 3
 	SPHINXBUILD="python -m sphinx -bhtml" $(MAKE) -C docs
+endif
 
 hgsrc_defined:
 	# Use "! -z" instead of "-n", because "-n" without arguments is true