debian/rules
branchstable
changeset 4913 cac7e750422f
parent 4911 ddfc0b16c9d7
child 5294 29f3680823e9
--- a/debian/rules	Fri Oct 18 10:17:53 2019 +0200
+++ b/debian/rules	Fri Oct 11 16:53:52 2019 +0200
@@ -2,7 +2,7 @@
 #export DH_VERBOSE=1
 
 %:
-	dh $@ --with python2,sphinxdoc --buildsystem=pybuild
+	dh $@ --with python2,python3,sphinxdoc --buildsystem=pybuild
 
 ifeq (,$(filter nodoc, $(DEB_BUILD_OPTIONS)))
 override_dh_auto_build:
@@ -25,6 +25,11 @@
 	find debian -path '*/hgext3rd/__init__.py' -delete
 	dh_python2
 
+override_dh_python3:
+	# avoid conflict with mercurial's own hgext3rd/__init__.py
+	find debian -path '*/hgext3rd/__init__.py' -delete
+	dh_python3
+
 override_dh_auto_clean: clean-docs
 	dh_auto_clean
 	rm -f tests/*.err