equal
deleted
inserted
replaced
1 #!/usr/bin/make -f |
1 #!/usr/bin/make -f |
2 |
2 |
3 %: |
3 clean %: |
4 dh $@ --with python2 --buildsystem=python_distutils |
4 dh $@ --with python2 --buildsystem=python_distutils |
5 |
5 |
6 build: |
6 build: |
7 dh build --with python2 --buildsystem=python_distutils |
7 dh build --with python2 --buildsystem=python_distutils |
8 $(MAKE) -C docs |
8 $(MAKE) -C docs |
9 |
|
10 .PHONY: build |
|
11 |
9 |
12 ifeq (,$(filter nocheck, $(DEB_BUILD_OPTIONS))) |
10 ifeq (,$(filter nocheck, $(DEB_BUILD_OPTIONS))) |
13 override_dh_auto_test: |
11 override_dh_auto_test: |
14 cd tests && python run-tests.py --with-hg=`which hg` |
12 cd tests && python run-tests.py --with-hg=`which hg` |
15 endif |
13 endif |
16 |
14 |
17 override_dh_python2: |
15 override_dh_python2: |
18 # avoid conflict with mercurial's own hgext/__init__.py |
16 # avoid conflict with mercurial's own hgext/__init__.py |
19 find debian -name __init__.py -delete |
17 find debian -name __init__.py -delete |
20 dh_python2 |
18 dh_python2 |
|
19 |
|
20 clean: clean-docs |
|
21 |
|
22 clean-docs: |
|
23 rm -rf html |
|
24 rm -f docs/static/logo-evolve.ico |
|
25 rm -f docs/tutorials/tutorial.rst |
|
26 |
|
27 .PHONY: build clean clean-docs |