debian/rules
branchstable
changeset 725 235a942eba3f
parent 535 47246c32e0fb
child 735 d3bfd03cb26e
equal deleted inserted replaced
724:fa049c1d9445 725:235a942eba3f
     7 	dh build --with python2 --buildsystem=python_distutils
     7 	dh build --with python2 --buildsystem=python_distutils
     8 	$(MAKE) -C docs
     8 	$(MAKE) -C docs
     9 
     9 
    10 .PHONY: build
    10 .PHONY: build
    11 
    11 
       
    12 ifeq (,$(filter nocheck, $(DEB_BUILD_OPTIONS)))
    12 override_dh_auto_test:
    13 override_dh_auto_test:
    13 	cd tests &&  python run-tests.py --with-hg=`which hg`
    14 	cd tests &&  python run-tests.py --with-hg=`which hg`
       
    15 endif
    14 
    16 
    15 override_dh_python2:
    17 override_dh_python2:
    16 	# avoid conflict with mercurial's own hgext/__init__.py
    18 	# avoid conflict with mercurial's own hgext/__init__.py
    17 	find debian -name __init__.py -delete
    19 	find debian -name __init__.py -delete
    18 	dh_python2
    20 	dh_python2