debian/rules
changeset 573 5a0a01c4c7c2
parent 535 47246c32e0fb
child 725 235a942eba3f
equal deleted inserted replaced
498:53d7e3413337 573:5a0a01c4c7c2
       
     1 #!/usr/bin/make -f
       
     2 
       
     3 %:
       
     4 	dh $@ --with python2 --buildsystem=python_distutils
       
     5 
       
     6 build:
       
     7 	dh build --with python2 --buildsystem=python_distutils
       
     8 	$(MAKE) -C docs
       
     9 
       
    10 .PHONY: build
       
    11 
       
    12 override_dh_auto_test:
       
    13 	cd tests &&  python run-tests.py --with-hg=`which hg`
       
    14 
       
    15 override_dh_python2:
       
    16 	# avoid conflict with mercurial's own hgext/__init__.py
       
    17 	find debian -name __init__.py -delete
       
    18 	dh_python2