[debian] Install cubicweb-ctl from python2 build
Previously, the binary package was empty. Now it is bound to
the python2 package as support for python3 is "fresh".
In order python2 and python3 packages to be co-installable, we drop the
cubicweb-ctl file from both packages.
#!/usr/bin/make -f
# Sample debian/rules that uses debhelper.
# GNU copyright 1997 to 1999 by Joey Hess.
# Uncomment this to turn on verbose mode.
# export DH_VERBOSE=1
export PYBUILD_NAME=cubicweb
export PYBUILD_DISABLE_python2=test
export PYBUILD_DISABLE_python3=test
%:
dh $@ --with python2,python3,sphinxdoc --buildsystem=pybuild
override_dh_auto_build: export http_proxy=127.0.0.1:9
override_dh_auto_build: export https_proxy=127.0.0.1:9
override_dh_auto_build:
dh_auto_build
ifeq (,$(findstring nodocs, $(DEB_BUILD_OPTIONS)))
PYTHONPATH=. sphinx-build -N -bhtml doc/ debian/cubicweb-doc/html
endif
override_dh_installchangelogs:
dh_installchangelogs -Xdoc/changes
override_dh_auto_install:
dh_auto_install
mkdir -p debian/cubicweb-ctl/usr/bin
mv debian/python-cubicweb/usr/bin/cubicweb-ctl debian/cubicweb-ctl/usr/bin
rm debian/python3-cubicweb/usr/bin/cubicweb-ctl