debian/rules
author Denis Laxalde <denis.laxalde@logilab.fr>
Thu, 20 Jun 2019 17:02:59 +0200
branch3.26
changeset 12664 2337c8c05657
parent 12631 8f22b69ea890
child 12665 112f3c2b6f1e
permissions -rwxr-xr-x
[debian] Introduce python3-cubicweb and python3-cubicweb-pyramid binary packages This is the bare minimum to have a working cubicweb on python3. Further work is done in default branch.

#!/usr/bin/make -f
# Sample debian/rules that uses debhelper.
# GNU copyright 1997 to 1999 by Joey Hess.

# Uncomment this to turn on verbose mode.
# export DH_VERBOSE=1

export PYBUILD_NAME=cubicweb
export PYBUILD_DISABLE_python2=test
export PYBUILD_DISABLE_python3=test

%:
	dh $@ --with python2,python3,sphinxdoc --buildsystem=pybuild

override_dh_auto_build: export http_proxy=127.0.0.1:9
override_dh_auto_build: export https_proxy=127.0.0.1:9
override_dh_auto_build:
	dh_auto_build
ifeq (,$(findstring nodocs, $(DEB_BUILD_OPTIONS)))
	PYTHONPATH=. sphinx-build -N -bhtml doc/ debian/cubicweb-doc/html
endif

override_dh_installchangelogs:
	dh_installchangelogs -Xdoc/changes