setup.py
changeset 6842 117b53c10d79
parent 6836 fb3633142d8f
child 7879 9aae456abab5
--- a/setup.py	Fri Jan 14 08:10:41 2011 +0100
+++ b/setup.py	Wed Jan 19 09:31:15 2011 +0100
@@ -194,9 +194,10 @@
         old_ok = DS._ok
         def _ok(self, path):
             """Return True if ``path`` can be written during installation."""
-            out = old_ok(self, path)
+            out = old_ok(self, path) # here for side effect from setuptools
             realpath = os.path.normcase(os.path.realpath(path))
-            if realpath.startswith(sys.prefix):
+            allowed_path = os.path.normcase(sys.prefix)
+            if realpath.startswith(allowed_path):
                 out = True
             return out
         DS._ok = _ok