setup.py
branchstable
changeset 6836 fb3633142d8f
parent 6537 308037210dab
child 7879 9aae456abab5
--- a/setup.py	Mon Jan 17 12:43:07 2011 +0100
+++ b/setup.py	Mon Jan 17 13:36:18 2011 +0100
@@ -194,9 +194,10 @@
         old_ok = DS._ok
         def _ok(self, path):
             """Return True if ``path`` can be written during installation."""
-            out = old_ok(self, path)
+            out = old_ok(self, path) # here for side effect from setuptools
             realpath = os.path.normcase(os.path.realpath(path))
-            if realpath.startswith(sys.prefix):
+            allowed_path = os.path.normcase(sys.prefix)
+            if realpath.startswith(allowed_path):
                 out = True
             return out
         DS._ok = _ok