debian/rules
branch3.23
changeset 11394 f0188639e544
parent 10992 228b6d2777e4
child 11424 1451f040555f
equal deleted inserted replaced
11393:e148b384a782 11394:f0188639e544
     9 build-stamp:
     9 build-stamp:
    10 	dh_testdir
    10 	dh_testdir
    11 	NO_SETUPTOOLS=1 python setup.py build
    11 	NO_SETUPTOOLS=1 python setup.py build
    12 	# cubicweb.foo needs to be importable by sphinx, so create a cubicweb symlink to the source dir
    12 	# cubicweb.foo needs to be importable by sphinx, so create a cubicweb symlink to the source dir
    13 	mkdir -p debian/pythonpath
    13 	mkdir -p debian/pythonpath
    14 	ln -sf $(CURDIR) debian/pythonpath/cubicweb
    14 	ln -sf $(CURDIR)/cubicweb debian/pythonpath
    15 	# documentation build is now made optional since it can break for old
    15 	# documentation build is now made optional since it can break for old
    16 	# distributions and we don't want to block a new release of Cubicweb
    16 	# distributions and we don't want to block a new release of Cubicweb
    17 	# because of documentation issues.
    17 	# because of documentation issues.
    18 	-PYTHONPATH=$${PYTHONPATH:+$${PYTHONPATH}:}$(CURDIR)/debian/pythonpath $(MAKE) -C doc all
    18 	-PYTHONPATH=$${PYTHONPATH:+$${PYTHONPATH}:}$(CURDIR)/debian/pythonpath $(MAKE) -C doc all
    19 	rm -rf debian/pythonpath
    19 	rm -rf debian/pythonpath