equal
deleted
inserted
replaced
6 #export DH_VERBOSE=1 |
6 #export DH_VERBOSE=1 |
7 |
7 |
8 build: build-stamp |
8 build: build-stamp |
9 build-stamp: |
9 build-stamp: |
10 dh_testdir |
10 dh_testdir |
11 NO_SETUPTOOLS=1 python setup.py build |
11 python setup.py build |
12 # cubicweb.foo needs to be importable by sphinx, so create a cubicweb symlink to the source dir |
12 # cubicweb.foo needs to be importable by sphinx, so create a cubicweb symlink to the source dir |
13 mkdir -p debian/pythonpath |
13 mkdir -p debian/pythonpath |
14 ln -sf $(CURDIR)/cubicweb debian/pythonpath |
14 ln -sf $(CURDIR)/cubicweb debian/pythonpath |
15 # documentation build is now made optional since it can break for old |
15 # documentation build is now made optional since it can break for old |
16 # distributions and we don't want to block a new release of Cubicweb |
16 # distributions and we don't want to block a new release of Cubicweb |
32 dh_testdir |
32 dh_testdir |
33 dh_testroot |
33 dh_testroot |
34 dh_clean |
34 dh_clean |
35 dh_installdirs |
35 dh_installdirs |
36 |
36 |
37 NO_SETUPTOOLS=1 python setup.py -q install --no-compile --prefix=debian/tmp/usr |
37 python setup.py -q install --no-compile --prefix=debian/tmp/usr |
38 |
38 |
39 # Put all the python library and data in cubicweb-common |
39 # Put all the python library and data in cubicweb-common |
40 # and scripts in cubicweb-server |
40 # and scripts in cubicweb-server |
41 dh_install -vi --sourcedir=debian/tmp |
41 dh_install -vi --sourcedir=debian/tmp |
42 # cwctl in the cubicweb-ctl package |
42 # cwctl in the cubicweb-ctl package |