skeleton/debian/rules.tmpl
changeset 0 b97547f5f1fa
child 1449 7751785c0815
equal deleted inserted replaced
-1:000000000000 0:b97547f5f1fa
       
     1 #!/usr/bin/make -f
       
     2 # Sample debian/rules that uses debhelper.
       
     3 # GNU copyright 1997 to 1999 by Joey Hess.
       
     4 
       
     5 # Uncomment this to turn on verbose mode.
       
     6 #export DH_VERBOSE=1
       
     7 build: build-stamp
       
     8 build-stamp: 
       
     9 	dh_testdir
       
    10 	python setup.py -q build
       
    11 	touch build-stamp
       
    12 
       
    13 clean: 
       
    14 	dh_testdir
       
    15 	dh_testroot
       
    16 	rm -f build-stamp configure-stamp
       
    17 	rm -rf build
       
    18 	find . -name "*.pyc" | xargs rm -f
       
    19 	dh_clean
       
    20 
       
    21 install: build
       
    22 	dh_testdir
       
    23 	dh_testroot
       
    24 	dh_clean -k
       
    25 	dh_installdirs -i
       
    26 	python setup.py -q install --no-compile --prefix=debian/%(distname)s/usr/
       
    27 
       
    28 
       
    29 # Build architecture-independent files here.
       
    30 binary-indep: build install
       
    31 	dh_testdir
       
    32 	dh_testroot
       
    33 	dh_install -i
       
    34 	dh_installchangelogs -i
       
    35 	dh_installexamples -i
       
    36 	dh_installdocs -i
       
    37 	dh_installman -i
       
    38 	dh_link -i
       
    39 	dh_compress -i -X.py -X.ini -X.xml -Xtest
       
    40 	dh_fixperms -i
       
    41 	dh_installdeb -i
       
    42 	dh_gencontrol -i 
       
    43 	dh_md5sums -i
       
    44 	dh_builddeb -i
       
    45 
       
    46 
       
    47 # Build architecture-dependent files here.
       
    48 binary-arch: 
       
    49 
       
    50 binary: binary-indep 
       
    51 .PHONY: build clean binary-arch binary-indep binary