skeleton/debian/rules.tmpl
branchtls-sprint
changeset 1449 7751785c0815
parent 0 b97547f5f1fa
child 1667 145af5f29f12
equal deleted inserted replaced
1448:62f099f0916f 1449:7751785c0815
     3 # GNU copyright 1997 to 1999 by Joey Hess.
     3 # GNU copyright 1997 to 1999 by Joey Hess.
     4 
     4 
     5 # Uncomment this to turn on verbose mode.
     5 # Uncomment this to turn on verbose mode.
     6 #export DH_VERBOSE=1
     6 #export DH_VERBOSE=1
     7 build: build-stamp
     7 build: build-stamp
     8 build-stamp: 
     8 build-stamp:
     9 	dh_testdir
     9 	dh_testdir
    10 	python setup.py -q build
    10 	python setup.py -q build
    11 	touch build-stamp
    11 	touch build-stamp
    12 
    12 
    13 clean: 
    13 clean:
    14 	dh_testdir
    14 	dh_testdir
    15 	dh_testroot
    15 	dh_testroot
    16 	rm -f build-stamp configure-stamp
    16 	rm -f build-stamp configure-stamp
    17 	rm -rf build
    17 	rm -rf build
    18 	find . -name "*.pyc" | xargs rm -f
    18 	find . -name "*.pyc" | xargs rm -f
    22 	dh_testdir
    22 	dh_testdir
    23 	dh_testroot
    23 	dh_testroot
    24 	dh_clean -k
    24 	dh_clean -k
    25 	dh_installdirs -i
    25 	dh_installdirs -i
    26 	python setup.py -q install --no-compile --prefix=debian/%(distname)s/usr/
    26 	python setup.py -q install --no-compile --prefix=debian/%(distname)s/usr/
       
    27 	# remove generated .egg-info file
       
    28 	rm -rf debian/cubicweb-comment/usr/lib/python*
    27 
    29 
    28 
    30 
    29 # Build architecture-independent files here.
    31 # Build architecture-independent files here.
    30 binary-indep: build install
    32 binary-indep: build install
    31 	dh_testdir
    33 	dh_testdir
    37 	dh_installman -i
    39 	dh_installman -i
    38 	dh_link -i
    40 	dh_link -i
    39 	dh_compress -i -X.py -X.ini -X.xml -Xtest
    41 	dh_compress -i -X.py -X.ini -X.xml -Xtest
    40 	dh_fixperms -i
    42 	dh_fixperms -i
    41 	dh_installdeb -i
    43 	dh_installdeb -i
    42 	dh_gencontrol -i 
    44 	dh_gencontrol -i
    43 	dh_md5sums -i
    45 	dh_md5sums -i
    44 	dh_builddeb -i
    46 	dh_builddeb -i
    45 
    47 
    46 
    48 
    47 # Build architecture-dependent files here.
    49 # Build architecture-dependent files here.
    48 binary-arch: 
    50 binary-arch:
    49 
    51 
    50 binary: binary-indep 
    52 binary: binary-indep
    51 .PHONY: build clean binary-arch binary-indep binary
    53 .PHONY: build clean binary-arch binary-indep binary