equal
deleted
inserted
replaced
|
1 #!/usr/bin/make -f |
|
2 # Sample debian/rules that uses debhelper. |
|
3 # GNU copyright 1997 to 1999 by Joey Hess. |
|
4 |
|
5 # Uncomment this to turn on verbose mode. |
|
6 #export DH_VERBOSE=1 |
|
7 build: build-arch build-indep |
|
8 build-arch: |
|
9 # Nothing to do |
|
10 build-indep: build-stamp |
|
11 build-stamp: |
|
12 dh_testdir |
|
13 NO_SETUPTOOLS=1 python setup.py -q build |
|
14 touch build-stamp |
|
15 |
|
16 clean: |
|
17 dh_testdir |
|
18 rm -f build-stamp configure-stamp |
|
19 rm -rf build |
|
20 find . -name "*.pyc" -delete |
|
21 dh_clean |
|
22 |
|
23 install: build |
|
24 dh_testdir |
|
25 dh_testroot |
|
26 dh_clean -k |
|
27 dh_installdirs -i |
|
28 NO_SETUPTOOLS=1 python setup.py -q install --no-compile --prefix=debian/cubicweb-pyramid/usr/ |
|
29 # remove generated .egg-info file |
|
30 rm -rf debian/cubicweb-pyramid/usr/lib/python* |
|
31 |
|
32 |
|
33 # Build architecture-independent files here. |
|
34 binary-indep: build install |
|
35 dh_testdir |
|
36 dh_testroot |
|
37 dh_install -i |
|
38 dh_installchangelogs -i |
|
39 dh_installexamples -i |
|
40 dh_installdocs -i README |
|
41 dh_installman -i |
|
42 dh_pysupport -i /usr/share/cubicweb |
|
43 dh_link -i |
|
44 dh_compress -i -X.py -X.ini -X.xml -Xtest |
|
45 dh_fixperms -i |
|
46 dh_installdeb -i |
|
47 dh_gencontrol -i |
|
48 dh_md5sums -i |
|
49 dh_builddeb -i |
|
50 |
|
51 |
|
52 # Build architecture-dependent files here. |
|
53 binary-arch: |
|
54 |
|
55 binary: binary-indep |
|
56 .PHONY: build clean binary-arch binary-indep binary |