debian/rules
changeset 11632 b05f361db666
child 11653 18939907a115
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/debian/rules	Fri Sep 05 12:32:03 2014 +0200
@@ -0,0 +1,56 @@
+#!/usr/bin/make -f
+# Sample debian/rules that uses debhelper.
+# GNU copyright 1997 to 1999 by Joey Hess.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+build: build-arch build-indep
+build-arch:
+	# Nothing to do
+build-indep: build-stamp
+build-stamp:
+	dh_testdir
+	NO_SETUPTOOLS=1 python setup.py -q build
+	touch build-stamp
+
+clean:
+	dh_testdir
+	rm -f build-stamp configure-stamp
+	rm -rf build
+	find . -name "*.pyc" -delete
+	dh_clean
+
+install: build
+	dh_testdir
+	dh_testroot
+	dh_clean -k
+	dh_installdirs -i
+	NO_SETUPTOOLS=1 python setup.py -q install --no-compile --prefix=debian/cubicweb-pyramid/usr/
+	# remove generated .egg-info file
+	rm -rf debian/cubicweb-pyramid/usr/lib/python*
+
+
+# Build architecture-independent files here.
+binary-indep: build install
+	dh_testdir
+	dh_testroot
+	dh_install -i
+	dh_installchangelogs -i
+	dh_installexamples -i
+	dh_installdocs -i README
+	dh_installman -i
+	dh_pysupport -i /usr/share/cubicweb
+	dh_link -i
+	dh_compress -i -X.py -X.ini -X.xml -Xtest
+	dh_fixperms -i
+	dh_installdeb -i
+	dh_gencontrol -i
+	dh_md5sums -i
+	dh_builddeb -i
+
+
+# Build architecture-dependent files here.
+binary-arch:
+
+binary: binary-indep
+.PHONY: build clean binary-arch binary-indep binary