debian/rules
branchstable
changeset 3936 0fc300eb4746
parent 2413 b1bea4cab594
child 3998 94cc7cad3d2d
equal deleted inserted replaced
3935:2fbb79054a1a 3936:0fc300eb4746
     6 #export DH_VERBOSE=1
     6 #export DH_VERBOSE=1
     7 
     7 
     8 PY_VERSION:=$(shell pyversions -d)
     8 PY_VERSION:=$(shell pyversions -d)
     9 
     9 
    10 build: build-stamp
    10 build: build-stamp
    11 build-stamp: 
    11 build-stamp:
    12 	dh_testdir
    12 	dh_testdir
    13 	# XXX doesn't work if logilab-doctools, logilab-xml are not in build depends
    13 	# XXX doesn't work if logilab-doctools, logilab-xml are not in build depends
    14 	# and I can't get pbuilder find them in its chroot :(
    14 	# and I can't get pbuilder find them in its chroot :(
    15 	# cd doc && make
    15 	# cd doc && make
    16 	# FIXME cleanup and use sphinx-build as build-depends ?
    16 	# FIXME cleanup and use sphinx-build as build-depends ?
    17 	python setup.py build
    17 	python setup.py build
    18 	touch build-stamp
    18 	touch build-stamp
    19 
    19 
    20 clean: 
    20 clean:
    21 	dh_testdir
    21 	dh_testdir
    22 	dh_testroot
    22 	dh_testroot
    23 	rm -f build-stamp configure-stamp
    23 	rm -f build-stamp configure-stamp
    24 	rm -rf build
    24 	rm -rf build
    25 	#rm -rf debian/cubicweb-*/
    25 	#rm -rf debian/cubicweb-*/
    79 	dh_md5sums -i
    79 	dh_md5sums -i
    80 	dh_builddeb -i
    80 	dh_builddeb -i
    81 
    81 
    82 binary-arch:
    82 binary-arch:
    83 
    83 
    84 binary: binary-indep 
    84 binary: binary-indep
    85 .PHONY: build clean binary binary-indep binary-arch
    85 .PHONY: build clean binary binary-indep binary-arch
    86 
    86