debian/rules
author Jordi Gutiérrez Hermoso <jordigh@octave.org>
Mon, 14 Apr 2014 15:10:29 -0400
changeset 909 ff71b83a4bbe
parent 735 d3bfd03cb26e
child 999 38099dfdcbbe
permissions -rwxr-xr-x
rewrite: use cmdutil.logmessage instead of ad-hoc methods The logic for handling the --message and --logfile options is already in core hg in the cmdutil.logmessage function. This patch removes this duplicate logic from Evolve and just calls the core function.

#!/usr/bin/make -f

clean %:
	dh $@ --with python2 --buildsystem=python_distutils

build:
	dh build --with python2 --buildsystem=python_distutils
	$(MAKE) -C docs

ifeq (,$(filter nocheck, $(DEB_BUILD_OPTIONS)))
override_dh_auto_test:
	cd tests &&  python run-tests.py --with-hg=`which hg`
endif

override_dh_python2:
	# avoid conflict with mercurial's own hgext/__init__.py
	find debian -name __init__.py -delete
	dh_python2

clean: clean-docs

clean-docs:
	rm -rf html
	rm -f docs/static/logo-evolve.ico
	rm -f docs/tutorials/tutorial.rst

.PHONY: build clean clean-docs