debian/rules
author Faheem Mitha <faheem@faheem.info>
Sat, 11 Oct 2014 04:23:22 +0530
changeset 1125 f14163c7275a
parent 1124 25e8f9c43f8a
child 1126 aef5e42a4fde
permissions -rwxr-xr-x
debian: replace build line with a override_dh_auto_build line This is more in line with how dh is supposed to work. In particular, dh_auto_build is functionally equivalent to the repeated "dh build --with python2 --buildsystem=python_distutils" used currently.

#!/usr/bin/make -f
#export DH_VERBOSE=1

%:
	dh $@ --with python2 --buildsystem=python_distutils

override_dh_auto_build:
	dh_auto_build
	$(MAKE) -C docs

ifeq (,$(filter nocheck, $(DEB_BUILD_OPTIONS)))
override_dh_auto_test:
	cd tests &&  python run-tests.py --with-hg=`which hg`
endif

override_dh_python2:
	# avoid conflict with mercurial's own hgext/__init__.py
	find debian -name __init__.py -delete
	dh_python2

clean: clean-docs
	rm -f tests/*.err

clean-docs:
	rm -rf html
	rm -f docs/static/logo-evolve.ico
	rm -f docs/tutorials/tutorial.rst

.PHONY: build clean clean-docs