debian/rules
author Pierre-Yves David <pierre-yves.david@logilab.fr>
Mon, 03 Jun 2013 15:06:18 +0200
changeset 730 ea629193a25e
parent 725 235a942eba3f
child 735 d3bfd03cb26e
permissions -rwxr-xr-x
merge stable into default

#!/usr/bin/make -f

%:
	dh $@ --with python2 --buildsystem=python_distutils

build:
	dh build --with python2 --buildsystem=python_distutils
	$(MAKE) -C docs

.PHONY: build

ifeq (,$(filter nocheck, $(DEB_BUILD_OPTIONS)))
override_dh_auto_test:
	cd tests &&  python run-tests.py --with-hg=`which hg`
endif

override_dh_python2:
	# avoid conflict with mercurial's own hgext/__init__.py
	find debian -name __init__.py -delete
	dh_python2