debian/rules
author Greg Ward <greg@gerg.ca>
Thu, 23 Apr 2015 08:35:38 -0400 (2015-04-23)
branchstable
changeset 1284 e33990a4c27a
parent 1165 f0978cb993a0
child 1565 9590332b26c8
permissions -rwxr-xr-x
docs: add a table of contents This silences many sphinx warnings about documents not included in any toctree. Still need to delete obsolete .rst files to silence the rest of the warnings.
#!/usr/bin/make -f
#export DH_VERBOSE=1

%:
	dh $@ --with python2 --buildsystem=python_distutils

override_dh_auto_build:
	dh_auto_build
	$(MAKE) -C docs

ifeq (,$(filter nocheck, $(DEB_BUILD_OPTIONS)))
override_dh_auto_test:
	cd tests &&  python run-tests.py --with-hg=`which hg` --blacklist=$(CURDIR)/debian/test-blacklist
endif

override_dh_python2:
	# avoid conflict with mercurial's own hgext/__init__.py
	find debian -name __init__.py -delete
	dh_python2

override_dh_auto_clean: clean-docs
	dh_auto_clean
	rm -f tests/*.err

clean-docs:
	rm -rf html
	rm -f docs/static/logo-evolve.ico
	rm -f docs/tutorials/tutorial.rst