debian/rules
author Pierre-Yves David <pierre-yves.david@ens-lyon.org>
Fri, 15 Nov 2013 21:44:24 -0500
changeset 752 bfdfdf731f8a
parent 735 d3bfd03cb26e
child 999 38099dfdcbbe
permissions -rwxr-xr-x
grab: update the alias for 2.8 compatibility 2.8 does not update on rebase anymore. We need to update by hand. this makes this alias more fragile.

#!/usr/bin/make -f

clean %:
	dh $@ --with python2 --buildsystem=python_distutils

build:
	dh build --with python2 --buildsystem=python_distutils
	$(MAKE) -C docs

ifeq (,$(filter nocheck, $(DEB_BUILD_OPTIONS)))
override_dh_auto_test:
	cd tests &&  python run-tests.py --with-hg=`which hg`
endif

override_dh_python2:
	# avoid conflict with mercurial's own hgext/__init__.py
	find debian -name __init__.py -delete
	dh_python2

clean: clean-docs

clean-docs:
	rm -rf html
	rm -f docs/static/logo-evolve.ico
	rm -f docs/tutorials/tutorial.rst

.PHONY: build clean clean-docs