debian/rules
author Pierre-Yves David <pierre-yves.david@fb.com>
Fri, 08 Aug 2014 15:50:26 -0700
branchstable
changeset 1031 acc2b590edd9
parent 735 d3bfd03cb26e
child 999 38099dfdcbbe
permissions -rwxr-xr-x
Added tag 4.0.1 for changeset e914884fb721

#!/usr/bin/make -f

clean %:
	dh $@ --with python2 --buildsystem=python_distutils

build:
	dh build --with python2 --buildsystem=python_distutils
	$(MAKE) -C docs

ifeq (,$(filter nocheck, $(DEB_BUILD_OPTIONS)))
override_dh_auto_test:
	cd tests &&  python run-tests.py --with-hg=`which hg`
endif

override_dh_python2:
	# avoid conflict with mercurial's own hgext/__init__.py
	find debian -name __init__.py -delete
	dh_python2

clean: clean-docs

clean-docs:
	rm -rf html
	rm -f docs/static/logo-evolve.ico
	rm -f docs/tutorials/tutorial.rst

.PHONY: build clean clean-docs