debian/rules
author Dan Villiom Podlaski Christiansen <dan@cabo.dk>
Fri, 15 Nov 2013 21:33:54 -0500
changeset 751 a5474648a9d2
parent 735 d3bfd03cb26e
child 999 38099dfdcbbe
permissions -rwxr-xr-x
gdown/gup: add next/previous alias Up and down refer to the customary order in log output rather than concepts; as such, it may be confusing to the user. I for one found them suprising -- they just didn't fit with my mental model. Previous and next, however, imply a clear parent/child relationship. We attroduce the new name as aliases for now.

#!/usr/bin/make -f

clean %:
	dh $@ --with python2 --buildsystem=python_distutils

build:
	dh build --with python2 --buildsystem=python_distutils
	$(MAKE) -C docs

ifeq (,$(filter nocheck, $(DEB_BUILD_OPTIONS)))
override_dh_auto_test:
	cd tests &&  python run-tests.py --with-hg=`which hg`
endif

override_dh_python2:
	# avoid conflict with mercurial's own hgext/__init__.py
	find debian -name __init__.py -delete
	dh_python2

clean: clean-docs

clean-docs:
	rm -rf html
	rm -f docs/static/logo-evolve.ico
	rm -f docs/tutorials/tutorial.rst

.PHONY: build clean clean-docs