next: solve the issue of `next` get confused by split
This patch solve a problem of next command which get confused by split.
Let me describe how it was getting confused:
Initial state of repo:
A---B---C
After splitting B to (B1,B2):
@
A---B1---B2
\
---B---C
X *
(note: C is orphan; checkedout to B1)
Lets make an amend on B1:
@
B1'
/
A---B1---B2
\ X *
\
---B---C
X *
Now, if run `hg next` (--evolve is True by default now):
$ it would give you choice to choose from B2 and C thinking that C could also
be a possbile children for B1, instead of stablizing B2 on B1.
I fixed this problem by filtering those aspiring children which can be
stablized on one of the aspiring children itself.
Changes made in test-prev-next.t shows the changed expected behaviour.
This software was downloaded from
https://www.mercurial-scm.org/repo/evolve/
Copyright 2011 Peter Arrenbrecht <peter.arrenbrecht@gmail.com>
Logilab SA <contact@logilab.fr>
Pierre-Yves David <pierre-yves.david@ens-lyon.org>
Patrick Mezard <patrick@mezard.eu>
This software may be used and distributed according to the terms of the GNU
General Public License version 2 or any later version.
On Debian systems, the complete text of the GNU General Public License version
2 can be found in `/usr/share/common-licenses/GPL-2'.