debian/rules
author Pierre-Yves David <pierre-yves.david@fb.com>
Fri, 25 Apr 2014 14:14:29 -0700
branchstable
changeset 1101 8cac667a0d7d
parent 999 38099dfdcbbe
child 1123 d6c065a7a6b1
permissions -rwxr-xr-x
prune: work around lazy revset slowdown Since 3.0 lazy revset is making some revset very slow. We currently work around the issue by using a simple loop instead.

#!/usr/bin/make -f

clean %:
	dh $@ --with python2 --buildsystem=python_distutils

build:
	dh build --with python2 --buildsystem=python_distutils
	$(MAKE) -C docs

ifeq (,$(filter nocheck, $(DEB_BUILD_OPTIONS)))
override_dh_auto_test:
	cd tests &&  python run-tests.py --with-hg=`which hg`
endif

override_dh_python2:
	# avoid conflict with mercurial's own hgext/__init__.py
	find debian -name __init__.py -delete
	dh_python2

clean: clean-docs
	rm -f tests/*.err

clean-docs:
	rm -rf html
	rm -f docs/static/logo-evolve.ico
	rm -f docs/tutorials/tutorial.rst

.PHONY: build clean clean-docs