debian: remove .PHONY line completely
This does not work in the case of implicit pattern matching rules as
used by dh. Consider this example from Geoffrey Thomas:
$ ls -l
total 16
-rw-r--r-- 1 faheem faheem 17 Aug 16 20:27 blue.c
-rw-r--r-- 1 faheem faheem 17 Aug 16 20:27 green.c
-rw-r--r-- 1 faheem faheem 35 Aug 16 20:26 Makefile
-rw-r--r-- 1 faheem faheem 17 Aug 16 20:27 red.c
$ cat Makefile
%: %.c
gcc -o $@ $<
.PHONY: blue
$ make red
gcc -o red red.c
$ make green
gcc -o green green.c
$ make blue
make: Nothing to be done for blue'.
The Make manual
(http://www.gnu.org/software/make/manual/make.html#Phony-Targets) says
Since it knows that phony targets do not name actual files that
could be remade from other files, make skips the implicit rule
search for phony targets (see Implicit Rules).
Thanks to the good folks on #debian-mentors on OFTC for instruction
and explanation in these matters.
Source: mercurial-evolve
Section: vcs
Priority: optional
Maintainer: Logilab <contact@logilab.fr>
Uploaders:
Julien Cristau <julien.cristau@logilab.fr>,
Pierre-Yves David <pierre-yves.david@logilab.fr>,
Standards-Version: 3.9.3
Build-Depends:
mercurial (>=2.6~),
python,
debhelper (>= 8),
python-sphinx (>= 1.0.8),
imagemagick,
librsvg2-bin,
curl,
Python-Version: >= 2.6
Homepage: https://bitbucket.org/marmoute/mutable-history
Package: mercurial-evolve
Architecture: all
Depends:
${python:Depends},
${misc:Depends},
mercurial (>= 2.6),
Description: evolve extension for Mercurial
This package provides the experimental "evolve" extension for the Mercurial
DVCS.
.
This extension provides several commands to mutate history and deal with issues
it may raise.
.
It also:
- enables the "Changeset Obsolescence" feature of mercurial,
- alters core command and extension that rewrite history to use this feature,
- improves some aspects of the early implementation in Mercurial 2.3.
.
**These extensions are experimental and are not meant for production.**