debian/rules
author Julien Cristau <julien.cristau@logilab.fr>
Mon, 14 Apr 2014 18:16:35 +0200
branchstable
changeset 901 4f84b3307dc2
parent 735 d3bfd03cb26e
child 999 38099dfdcbbe
permissions -rwxr-xr-x
Fix preservation of rename information on evolve (#33) Following what rebase itself does, call duplicatecopies between rebasenode and concludenode. Should fix https://bitbucket.org/marmoute/mutable-history/issue/33/evolve-command-loses-copy-metadata

#!/usr/bin/make -f

clean %:
	dh $@ --with python2 --buildsystem=python_distutils

build:
	dh build --with python2 --buildsystem=python_distutils
	$(MAKE) -C docs

ifeq (,$(filter nocheck, $(DEB_BUILD_OPTIONS)))
override_dh_auto_test:
	cd tests &&  python run-tests.py --with-hg=`which hg`
endif

override_dh_python2:
	# avoid conflict with mercurial's own hgext/__init__.py
	find debian -name __init__.py -delete
	dh_python2

clean: clean-docs

clean-docs:
	rm -rf html
	rm -f docs/static/logo-evolve.ico
	rm -f docs/tutorials/tutorial.rst

.PHONY: build clean clean-docs