effectflag: allow to save effect of change in obsmarkers
Obsmarkers lack a precious information, what are the changes between
the source and the destination. This could be several thing:
- The description has changed, with a amend -e for example
- The parent has changed, with a rebase for example
- The content has changed, with a amend for example
- The meta, like the user, has change, with a amend -u for example
Or any combination of them.
We hijack the createobsmarkers in order to compute the modification
and store the effect flag which is basically a bitfield of the
changes list above and we store it in the metadata for the moment.
The advantage of computing the flag just before creating the obs marker
is that all commands will immediately be compatible and we can start
working on the UI display of the flag. As a future optimization,
the commands will be able to pass the flag directly or data to help computing
them, for example amend knows if the description has changed or rebase now if
the parent has changed, virtually removing the overhead.
To start simple, this patch add the detection and storage of the effect flag
when the description has changed. And hide it behind an experimental flag
disabled by default 'experimental.evolution.effect-flags'. More flag will
follow.
Source: mercurial-evolve
Section: vcs
Priority: optional
Maintainer: Logilab <contact@logilab.fr>
Uploaders:
Julien Cristau <julien.cristau@logilab.fr>,
Pierre-Yves David <pierre-yves.david@logilab.fr>,
Standards-Version: 3.9.3
Build-Depends:
mercurial (>= 3.4~),
python,
debhelper (>= 8),
python-sphinx (>= 1.0.8),
imagemagick,
librsvg2-bin,
wget,
Python-Version: >= 2.6
Homepage: https://www.mercurial-scm.org/doc/evolution/
Package: mercurial-evolve
Architecture: all
Depends:
${python:Depends},
${misc:Depends},
mercurial (>= 3.3~),
Description: evolve extension for Mercurial
This package provides the experimental "evolve" extension for the Mercurial
DVCS.
.
This extension provides several commands to mutate history and deal with issues
it may raise.
.
It also:
- enables the "Changeset Obsolescence" feature of mercurial,
- alters core command and extension that rewrite history to use this feature,
- improves some aspects of the early implementation in Mercurial 2.3.
.
**These extensions are experimental and are not meant for production.**