debian/rules
author Durham Goode <durham@fb.com>
Tue, 17 Mar 2015 19:04:16 -0700
changeset 1214 4b10e2c6f7e3
parent 1165 f0978cb993a0
child 1565 9590332b26c8
permissions -rwxr-xr-x
config: remove uses of obsolete._enabled Upstream Mercurial will be removing obsolete._enabled soon, so switch all our uses of it to use the new obsolete.isenabled(repo, option) function.

#!/usr/bin/make -f
#export DH_VERBOSE=1

%:
	dh $@ --with python2 --buildsystem=python_distutils

override_dh_auto_build:
	dh_auto_build
	$(MAKE) -C docs

ifeq (,$(filter nocheck, $(DEB_BUILD_OPTIONS)))
override_dh_auto_test:
	cd tests &&  python run-tests.py --with-hg=`which hg` --blacklist=$(CURDIR)/debian/test-blacklist
endif

override_dh_python2:
	# avoid conflict with mercurial's own hgext/__init__.py
	find debian -name __init__.py -delete
	dh_python2

override_dh_auto_clean: clean-docs
	dh_auto_clean
	rm -f tests/*.err

clean-docs:
	rm -rf html
	rm -f docs/static/logo-evolve.ico
	rm -f docs/tutorials/tutorial.rst