debian/rules
author Pierre-Yves David <pierre-yves.david@fb.com>
Fri, 25 Jul 2014 17:13:54 +0200
changeset 1007 1d8ba8244001
parent 999 38099dfdcbbe
child 1123 d6c065a7a6b1
permissions -rwxr-xr-x
push: put phase in the same bundle2 than changegroup and obsmarkers Note that the usual phase push from core will be performed in all case. But the discovery should find already in sync phase at that time. The old ways sync will be properly skipped when this logic is introduced into core.

#!/usr/bin/make -f

clean %:
	dh $@ --with python2 --buildsystem=python_distutils

build:
	dh build --with python2 --buildsystem=python_distutils
	$(MAKE) -C docs

ifeq (,$(filter nocheck, $(DEB_BUILD_OPTIONS)))
override_dh_auto_test:
	cd tests &&  python run-tests.py --with-hg=`which hg`
endif

override_dh_python2:
	# avoid conflict with mercurial's own hgext/__init__.py
	find debian -name __init__.py -delete
	dh_python2

clean: clean-docs
	rm -f tests/*.err

clean-docs:
	rm -rf html
	rm -f docs/static/logo-evolve.ico
	rm -f docs/tutorials/tutorial.rst

.PHONY: build clean clean-docs