debian/rules
author Pierre-Yves David <pierre-yves.david@fb.com>
Mon, 10 Mar 2014 21:34:36 -0700
changeset 875 10867a8e27c6
parent 735 d3bfd03cb26e
child 999 38099dfdcbbe
permissions -rwxr-xr-x
exchange: properly wrap wireprotocol capabilities Just wrapping the module function only works for ssh. Ssh gets capability through the `hello` command. We also need to wrap the function stored in the command dict. This fix discovery for http peer.

#!/usr/bin/make -f

clean %:
	dh $@ --with python2 --buildsystem=python_distutils

build:
	dh build --with python2 --buildsystem=python_distutils
	$(MAKE) -C docs

ifeq (,$(filter nocheck, $(DEB_BUILD_OPTIONS)))
override_dh_auto_test:
	cd tests &&  python run-tests.py --with-hg=`which hg`
endif

override_dh_python2:
	# avoid conflict with mercurial's own hgext/__init__.py
	find debian -name __init__.py -delete
	dh_python2

clean: clean-docs

clean-docs:
	rm -rf html
	rm -f docs/static/logo-evolve.ico
	rm -f docs/tutorials/tutorial.rst

.PHONY: build clean clean-docs