checkheads: handle partial obsolescence
We now properly detects situations were only parts of the remote branch is
obsoleted. To do so, we process children in the branch recursively to see if
they will be obsolete.
The current code has some trouble when the remote branch in unknown locally, or
when the prune happened on a successors that is not relevant to the push. These
case will be handled later.
The processing code is becoming more and more complex, a lighter approach would
be to check for the obsolescence markers that are relevant to the pushed set,
but I prefer to stick with the current approach until more test cases are
written.
#!/usr/bin/make -f
#export DH_VERBOSE=1
%:
dh $@ --with python2 --buildsystem=python_distutils
override_dh_auto_build:
dh_auto_build
$(MAKE) -C docs
hgsrc_defined:
# Use "! -z" instead of "-n", because "-n" without arguments is true
test ! -z $(HGSRC) && test -d $(HGSRC) || (echo "$(HGSRC) is not a directory"; false)
ifeq (,$(filter nocheck, $(DEB_BUILD_OPTIONS)))
override_dh_auto_test: hgsrc_defined
cd tests && python $(HGSRC)/tests/run-tests.py --with-hg=$(HGSRC)/hg --blacklist=$(CURDIR)/debian/test-blacklist
endif
override_dh_python2:
# avoid conflict with mercurial's own hgext3rd/__init__.py
find debian -path '*/hgext3rd/__init__.py' -delete
dh_python2
override_dh_auto_clean: clean-docs
dh_auto_clean
rm -f tests/*.err
clean-docs:
rm -rf html
rm -f docs/static/logo-evolve.ico
rm -f docs/tutorials/tutorial.rst