py3: return unicode from setup.py's get_version
py3 expects the version number for eggs to be unicode, so despite 9.2.0 being
the first evolve release with beta py3 support it isn't currently pip
installable since it dies with:
File "*/setuptools/command/egg_info.py", line *, in tagged_version
return safe_version(version + self.vtags)
TypeError: can't concat str to bytes
The `setup.py install` test added in a previous commit should cover this since
it died in a different but similar way before.
This software was downloaded from
https://www.mercurial-scm.org/repo/evolve/
Copyright 2011 Peter Arrenbrecht <peter.arrenbrecht@gmail.com>
Logilab SA <contact@logilab.fr>
Pierre-Yves David <pierre-yves.david@ens-lyon.org>
Patrick Mezard <patrick@mezard.eu>
This software may be used and distributed according to the terms of the GNU
General Public License version 2 or any later version.
On Debian systems, the complete text of the GNU General Public License version
2 can be found in `/usr/share/common-licenses/GPL-2'.