--- /dev/null Thu Jan 01 00:00:00 1970 +0000
+++ b/setup.py Fri Aug 24 11:39:22 2012 +0200
@@ -0,0 +1,25 @@
+# Copied from histedit setup.py
+# Credit to Augie Fackler <durin42@gmail.com>
+
+from distutils.core import setup
+
+requires = []
+try:
+ import mercurial
+except ImportError:
+ requires.append('mercurial')
+
+setup(
+ name='hg-evolve',
+ version='0.1.0',
+ author='Pierre-Yves David',
+ maintainer='Pierre-Yves David',
+ maintainer_email='pierre-yves.david@logilab.fr',
+ url='https://bitbucket.org/marmoute/mutable-history',
+ description='Flexible evolution of Mercurial history.',
+ long_description=open('README').read(),
+ keywords='hg mercurial',
+ license='GPLv2+',
+ py_modules=['hgext.evolve'],
+ install_requires=requires,
+)