setup.py
changeset 4792 9f2e480ad786
parent 3424 efac9aad0963
child 4817 a9b4c4849338
--- a/setup.py	Tue Jul 30 02:55:22 2019 +0200
+++ b/setup.py	Fri Jun 28 21:07:20 2019 +0000
@@ -7,7 +7,8 @@
 def get_metadata():
     meta = {}
     fullpath = join(dirname(__file__), META_PATH)
-    execfile(fullpath, meta)
+    with open(fullpath, 'r') as fp:
+        exec(fp.read(), meta)
     return meta
 
 def get_version():