equal
deleted
inserted
replaced
1 #!/usr/bin/make -f |
1 #!/usr/bin/make -f |
2 #export DH_VERBOSE=1 |
2 #export DH_VERBOSE=1 |
3 |
3 |
4 %: |
4 %: |
5 dh $@ --with python2 --buildsystem=python_distutils |
5 dh $@ --with python2,python3,sphinxdoc --buildsystem=pybuild |
6 |
6 |
|
7 ifeq (,$(filter nodoc, $(DEB_BUILD_OPTIONS))) |
7 override_dh_auto_build: |
8 override_dh_auto_build: |
8 dh_auto_build |
9 dh_auto_build |
9 # Workaround for Sphinx in Debian Buster defaulting to Python 3 |
10 # Workaround for Sphinx in Debian Buster defaulting to Python 3 |
10 SPHINXBUILD="python -m sphinx -bhtml" $(MAKE) -C docs |
11 SPHINXBUILD="python -m sphinx -bhtml" $(MAKE) -C docs |
|
12 endif |
11 |
13 |
12 hgsrc_defined: |
14 hgsrc_defined: |
13 # Use "! -z" instead of "-n", because "-n" without arguments is true |
15 # Use "! -z" instead of "-n", because "-n" without arguments is true |
14 test ! -z $(HGSRC) && test -d $(HGSRC) || (echo "$(HGSRC) is not a directory"; false) |
16 test ! -z $(HGSRC) && test -d $(HGSRC) || (echo "$(HGSRC) is not a directory"; false) |
15 |
17 |
21 override_dh_python2: |
23 override_dh_python2: |
22 # avoid conflict with mercurial's own hgext3rd/__init__.py |
24 # avoid conflict with mercurial's own hgext3rd/__init__.py |
23 find debian -path '*/hgext3rd/__init__.py' -delete |
25 find debian -path '*/hgext3rd/__init__.py' -delete |
24 dh_python2 |
26 dh_python2 |
25 |
27 |
|
28 override_dh_python3: |
|
29 # avoid conflict with mercurial's own hgext3rd/__init__.py |
|
30 find debian -path '*/hgext3rd/__init__.py' -delete |
|
31 dh_python3 |
|
32 |
26 override_dh_auto_clean: clean-docs |
33 override_dh_auto_clean: clean-docs |
27 dh_auto_clean |
34 dh_auto_clean |
28 rm -f tests/*.err |
35 rm -f tests/*.err |
29 |
36 |
30 clean-docs: |
37 clean-docs: |