debian/rules
branchmercurial-3.6
changeset 1604 61dd08f4dc62
parent 1565 9590332b26c8
child 2072 c0a685c67c5c
equal deleted inserted replaced
1601:15318c3460bf 1604:61dd08f4dc62
     6 
     6 
     7 override_dh_auto_build:
     7 override_dh_auto_build:
     8 	dh_auto_build
     8 	dh_auto_build
     9 	$(MAKE) -C docs
     9 	$(MAKE) -C docs
    10 
    10 
       
    11 hgsrc_defined:
       
    12 	# Use "! -z" instead of "-n", because "-n" without arguments is true
       
    13 	test ! -z $(HGSRC) && test -d $(HGSRC) || (echo "$(HGSRC) is not a directory"; false)
       
    14 
    11 ifeq (,$(filter nocheck, $(DEB_BUILD_OPTIONS)))
    15 ifeq (,$(filter nocheck, $(DEB_BUILD_OPTIONS)))
    12 override_dh_auto_test:
    16 override_dh_auto_test: hgsrc_defined
    13 	cd tests &&  python run-tests.py --with-hg=`which hg` --blacklist=$(CURDIR)/debian/test-blacklist
    17 	cd tests && python $(HGSRC)/tests/run-tests.py --with-hg=$(HGSRC)/hg --blacklist=$(CURDIR)/debian/test-blacklist
    14 endif
    18 endif
    15 
    19 
    16 override_dh_python2:
    20 override_dh_python2:
    17 	# avoid conflict with mercurial's own hgext/__init__.py
    21 	# avoid conflict with mercurial's own hgext/__init__.py
    18 	find debian -name __init__.py -delete
    22 	find debian -name __init__.py -delete